Drum Schedule

Comprehensive Learning Guide

Drum scheduling is a logical process of putting together pieces of cables to make a spool of cable.

Procurement of cables is generally transacted in unit of drum. During construction stage, the lay out (pulling) of cables are drawn out and cut from the drums. For these reasons, proper drum management is necessary to facilitate the procurement processes and to maximize the usage of the cable in the drums.

This guide was prepared for users to master the Drum Schedule feature of e-DPP, quickly and effectively. The basic concepts and process flows adopted by the program will be illustrated using the “Example2” project.
Contents

I. Stages of Drum Scheduling ..................................................................................................... 3
II. Flow of Drum Scheduling ..................................................................................................... 3
III. Exercise Using Example2 Project .......................................................................................... 4
  1. Opening the “Example 2” Project ....................................................................................... 4
  2. Verifying the Existence of a Cable Schedule ................................................................. 5
  3. Creating Drum Specification Table ................................................................................... 7
  4. Defining the Drum Naming Convention ......................................................................... 10
  5. Drum List and Drum Schedule Generation ................................................................. 15
  6. Drum List Editor .............................................................................................................. 17
  7. Drum Schedule Editor ..................................................................................................... 20
  8. Moving Cables from One Drum to Another ................................................................. 23
  9. Drum Consistency with the Cable Schedule .................................................................. 25
I. Stages of Drum Scheduling

Stage 1: Creation of “Drum List”
Drum list is a listing of cable drums complete with information about the specification of the cable. Generally, this list is used for procurement purposes.

Stage 2: Drum’s Allocation
Drum’s allocation is the process of segmenting the cable wound in a drum. The “Drum Schedule” table is created for this purpose. A Drum Schedule is a table of how the cable which is wound in the drum will be cut into pieces/sections. Generally, this schedule is used for construction purposes.

II. Flow of Drum Scheduling

A cable schedule is necessary before drum list and drum schedules can be generated. From the cable schedule, e-DPP will summarize all the cables distinctly and list them in a table called “Drum Specification”. A “Drum Specification” table also contains the criteria for the sizing (length of cable) of the drums.

Flow of Drum Scheduling
III. Exercise Using Example2 Project

In this exercise, the “Example2” project that comes with the software will be used. The following operations will be illustrated here:

1. Opening the “Example 2” Project.
   (1) Launch e-DPP V3.0.0.
   (2) On the “Login” dialog window, click “Cancel” button.

   ![Login Dialog Window]

   (3) On the main menu, select “File ➔ Open Project…” and browse to folder “C:\Program Files\eDPPv300\Example”, select and open “Example2.mdb” file.

   Note: The above path is valid if e-DPP program has been installed in the default folder.

   (4) On the “Login” dialog window, click the “OK” button.
2. Verifying the Existence of a Cable Schedule

In the “Example2.mdb” project, the Cable Schedule has been pre-defined.

(1) On the main menu, select “Edit→Cable→Cable Schedule (Form-1)” to open one of the Cable Schedules

(2) The “Cable Schedule (Form-1)” table will be displayed as follows. Initially, the table is filtered by “Power cables”

(3) Clear the filter in order to view all the cables associated to the loads. On the “MDI Editor” toolbar, click “Filter” icon. The “Filter” dialog window will be displayed. Click “Clear” and “OK” button on the “Filter” dialog window.
(4) Inspect the table as desired.

(5) Click the control button to close the “Cable Schedule (Form-1)” table.
3. Creating Drum Specification Table

Since Cable Schedule already exists, the drum specification table may be created.

(1) On the menu, select “Cable Management→Drum Scheduling…” or click icon from the “Cable Management” toolbar.

(2) The “Drum Schedule” dialog window will be displayed. Click “Edit Drum Specifications…” button.

(3) e-DPP will re-summarize the cable (base on specification) from the Cable Schedule to the “Drum Specification – Edit” dialog window. See the image on next page.

   The upper part of the dialog window is a table showing the summary of the cables. In the lower part are command buttons.

   On this window, do the following:

   a. In the “Drum Max. Length” frame, enter 1000 and click the “Update…” button. The value of the cells under the “Max. Length” of the table will be changed to “1000”.

      By default, the value on these cells will be initially populated from the library (if the particular cables exist in the library). Otherwise, a default of 1000 will be assigned.

   b. In the “Spare Length” frame, enter 5% and click the “Update…”button. The values of the cells under “Spare Length” column of the table will be changed to “50”

   c. Click the “Rated Voltage” header repeatedly to sort the records in by voltage in ascending order.
d. In the “Option” column of the table, for rows 1 to 3, select “Round Up” option.

“Round Up” option
When “Round Up” option is selected, the drum’s cable length will be dynamically calculated with maximum limit equal to the length specified in the “Max.Length” column. The drum length will be equaled to the sum of the cable segments plus the “Spare Length” plus a portion of the “Round Up Length” yielded by the rounding-up process. See illustration below:

Given

<table>
<thead>
<tr>
<th>Cable Segments</th>
<th>Drum Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>A: Cable 1 = 200m</td>
<td>D: Max. Length = 1000m</td>
</tr>
<tr>
<td>B: Cable 2 = 470m</td>
<td>E: Spare Length = 50m</td>
</tr>
<tr>
<td>C: Cable 3 = 100m</td>
<td>F: Round Up Length = 20m</td>
</tr>
<tr>
<td>D: Cable 4 = 190m</td>
<td></td>
</tr>
</tbody>
</table>

Drum Length = 830m

Drum No. 1

A
200m

B
470m

C
100m

D
190m

Actual Spare
60m

X = 10m

Drum No. 2

Drum Length = 250m

X = ((Round Up ((A+B+C)/(D+1)))*D*F) - (A+B+C)

= ((Round Up (250/190)*20)) - 770

= (41.6667*20) - 770

= 833.3333 - 770

= 63

Round Up Length
Illustration

X = 63

Spare Length
50m
e. Leave the “Max.Len” option to rows 4 to 33 intact.

“Max.Len” option
When “Max.Len” option is selected, the drum’s cable length is automatically equal to the value specified in the “Max.Length” column. The actual drum’s spare will be dynamically calculated but its minimum value is the value in the “Spare Length” column. See illustration below:

<table>
<thead>
<tr>
<th>Given</th>
<th>Drum Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cable Segments</td>
<td>Drum Criteria</td>
</tr>
<tr>
<td>A: Cable 1 = 200m</td>
<td>D: Max. Length = 1000m</td>
</tr>
<tr>
<td>B: Cable 2 = 470m</td>
<td>E: Spare Length = 50m</td>
</tr>
<tr>
<td>C: Cable 3 = 100m</td>
<td>F: Round Up Length = 20m (Not Applicable)</td>
</tr>
<tr>
<td>D: Cable 4 = 190m</td>
<td></td>
</tr>
</tbody>
</table>

f. Click “Save” and “Close” button
4. **Defining the Drum Naming Convention**

Consider the naming convention for the drum according to the following configuration:

![Diagram of Drum Naming Convention]

**Fig. A**

1. On the “Drum Schedule” dialog window, click “**Run Drum Scheduling**…” button.
(2) Click the “Edit” button in the “Drum No. – Naming Convention” frame (see the image on next page).
(3) The “Naming Convention – Edit” dialog window will be displayed. On this window, express the drum naming convention.

a. Assign the code to each fragment of the intended drum number according to “Fig. A” on page 10. Double click the “Code” column and enter (or select) the appropriate strings in the following sections respectively:

i. Rated Voltage
ii. Cable Type
iii. Cable Size
iv. User Text1
v. Serial Number
b. Assemble the fragments intended drum number as follows:

i. Point the mouse to the “User Text 1” and drag & drop to the 1st box in the “Convention Builder” frame.

ii. Point the mouse to the “Rated Voltage” area and drag & drop to the 2nd box in the “Convention Builder” frame.

iii. Point the mouse to the “Cable Type” area and drag & drop to the 3rd box in the “Convention Builder” frame.

iv. Point the mouse to the “Cable Size” area and drag & drop to the 4th box in the “Convention Builder” frame.

v. Point the mouse to the “Serial Number”, select “3” and drag & drop to the 5th box in the “Convention Builder” frame.

vi. Click “Clear 6” button as this fragment is not necessary.

vii. Uncheck the checkbox between “Clear 5” and “Clear6” button as this is not also necessary.

viii. Check the checkbox between “Clear3” and “Clear4” buttons to insert hyphen between the 4th and 5th section of the intended drum number.

ix. Similarly, check the checkbox between “Clear4” and “Clear5” buttons.
c. Observe the sample drum number. This is the resulting pattern of the naming convention.

d. Click “Save” and “Close” button
5. Drum List and Drum Schedule Generation

On the “Run Drum Scheduling” dialog window, do the following:

(1) In the “Scheduling Objects” frame, select “All” to all drop down lists.

These selections mean that all the cables (by type) shown in the “List of Cable Specification” list box are subject to drum scheduling.

(2) In the “Geographical Criteria” frame, select “All” also to all drop down lists.

These selections mean that all the cables in all locations of the plant are subject to drum scheduling.

(3) In the “Scheduling Scope” frame, select “All cables with & without drum no.”

This option will completely reset the existing drum schedules (if any).

Note:
If you do not want the existing drums to completely reset and you intend only to add the cables which have not been assigned yet a drum either to existing drum with ample of spare and/or to a new drum, select the option “Only cables without drum no.” check the sub-option “Include existing drums”. These options mean that if any of the existing drums has abundant spare, the spare will be allotted to the unscheduled cables. For example, if a certain drum has a spare of 300m cable and three unscheduled cables have length of 120m, 135m, and 180m respectively. The first 2 cables i.e. with 120m and 135m length will be schedule to the drum while the 3rd cable will be schedule to a new drum since it cannot fit to the existing drum anymore.

(4) In the “Orphan Control” frame, check “Site Areas” and “Substations” options.

This means the cables will be grouped by “Site Areas” location and then by “Substations” locations. See “Fig. B” on page 16 for illustration.

(5) Click “Run” button.
When the “Site Area” and “Substation” options are selected in the “Orphan Control”, the cables located in “S/S 01” in “UTIL” area will be scheduled to “Drum A” series while the cables located in “S/S 02” in “UTIL” area will be scheduled to “Drum B” series and so on.

If say that only the “Site Area” option is selected in the “Orphan Control”, the cables in the “UTIL” area will be scheduled to common drum(s) regardless of their sub-location (i.e. substation).

Fig. B

(6) Click “No” button on the subsequent dialog box. We will open the “Drum List Editor” dialog window later.

(7) Click “Close” button on the “Run Drum Scheduling” dialog window.
6. Drum List Editor

When the “Drum Scheduling” was executed in Section 5, the drums were created automatically.

(1) On the “Drum Schedule” dialog window, click “Edit Drum List…” button.

(2) The “Edit Drum Editor” dialog window will be displayed as follows:

The Drum List Editor table shows all the drums that were created (See Section 5.(5)). Total of 63 drums were created automatically. Notice the drum number “ELTECHS-HV-XSP-04000-002”, the spare length is “-250”. This occurred since a single cable measures 1250 meters and the maximum drum specified in the Section 3.(3).d was 1000m. e-DPP allows a cable to be scheduled on a single drum where the cable is measuring more that the length of the drum. However, e-DPP provides an indication (foreground color of the font changes to red) to alert the designer of the predicament. It’s up to the designer the n how to deal with the situation i.e. either to splice the cable due to improbability to manufacture a cable more than a certain length (e.g. 1000m) or pay the additional price for the special handling to manufacture such.
(3) In anticipation that a drum may be accidentally damaged due to mishandling during the construction, create a spare drum.

a. Click “Create New Drum” button.

b. The “Create New Drum No.” dialog window will be displayed. On this dialog, do the following:

i. Select/enter data as follows:

   - New Drum No. = ELTECHS-LV-PPO-00015-007
   - Data Source = <blank>
   - Conductor Type = Copper
   - Rated Voltage = 0.6/1kV
   - Cable Type = PVC/PVC
   - No. of Wires = 30/P
   - Cable Size = 1.5
   - Drum Length (m) = 1000

ii. Click “OK” button. A new drum will be created with 100% spare.

c. Click “Save”. Note, you will be prompted of alert message pointing out the issue discussed in Section 6.(2). Click “Yes” button anyway.
(4) Generate Drum List report in Excel.

a. Click “To Excel” button on the “Drum List Editor” dialog window.

b. The Excel report will be generated as shown below. You may have this now to facilitate the procurement of the cable. When done inspecting the output, close the Excel file without saving.

Click “Close” button on the “Drum List Editor” dialog window.
7. Drum Schedule Editor

When the “Drum Scheduling” was executed in Section 5, the cables were assigned to the drums automatically.


2. The “Drum Schedule – Edit” dialog window will be displayed. What you can do on this window are the following:
   - Generate Drum Schedule Report
   - Modify the cable information in terms of length, equipment origin and destination), and location.
(3) Generate a drum schedule report for drum “ELTECHS-LV-XSP-00160-001”.

a. Select the cable specs “Cu 0.6/1kV XLPE/SWA/PVC 3C-16 DPP” in the “List of Cable Specifications” list box. The objective of doing this is to filter the Drum list (shown in the “List of Drum” list box) by cable specification.

b. In the “List of Drum No.” list box, select “ELTECHS-LV-XSP-00160-001”.

Notice the right pane of the window. The upper portion shows the information about the drum and the lower portion shows the tabulation of the cable scheduled to the drum. In the table, you may edit the cable length, origin/destination equipment, and location.

c. Click the “To Excel” button. The “Export Drum Schedule to MS Excel” will be displayed.

d. On the “Export Drum Schedule to MS Excel” dialog window, do the following:

i. Select “Current Drum”

ii. Click “OK” button.

iii. The Excel report will be generated. See next page. When done inspecting the output, close the file without saving.

iv. Click “Cancel” button to exit.
e. On the “Drum Schedule – Edit” dialog window, click “Close” button to exit this window.
8. Moving Cables from One Drum to Another

(1) On the “Drum Schedule” dialog window, click “Move Drum Cables…” button.

(2) Move cable “GM-4002C-P” from drum “ELTECHS-MV-XSP-03000-001” to drum “ELTECHS-MV-XSP-03000-002”. See image on next page.

a. Select the cable specs “Cu 3.6/6kV XLPE/SWA/PVC 3C-300 DPP” in the “Cable Specifications” drop down list. This is the specification of cable “GM-4002C-P”.

Notice the drums shown in “Drum Data (1)” and “Drum Data(2)” frames. They are being filtered by selected cable specification.

b. On the “Drum Data(1)” frame, select the drum “ELTECHS-MV-XSP-03000-001” in the “Drum No.” list box.

Notice the table on the right of the “Drum No.” list box. It shows the cable segments currently assigned to the selected drum.

c. On the “Drum Data(2)” frame, select the drum “ELTECHS-MV-XSP-03000-002” in the “Drum No.” list box

Notice the table on the left of the list box (Drum No.). It shows the cable segments currently assigned to the selected drum.

d. Drag and drop cable “GM-4002C-P” from the left table to the right table.

e. Notice how the drum capacity varied with the movement of the cable.

f. Click “Save” and “Close” button to conclude.
(3) If you want to generate the drum schedule due to the changes made above, refer to section 7.(3) for similar procedure.

(4) Click “Close” button on the “Drum Schedule” dialog window to exit.
9. Drum Consistency with the Cable Schedule

By virtue of modifying cables information in Cable Schedule, inconsistency in the structure of the drum schedules and drum list may occur.

(1) On the main menu, select “Edit ➔ Cable ➔ Cable Schedule (Form-1)”.

(2) Change the drum assignment of cable “AM-2001-C1” from “ELTECHS-LV-XPO-00025-004” to “XYZ”.

(3) Click “Save” icon on the “Edit” toolbar.

(4) On the main menu, select “Cable Management ➔ Drum Scheduling”.

(5) On the “Drum Schedule” dialog window, click “Check Cable & Drum Data…” button.
(6) The “Check Cable & Drum Data” dialog window will be displayed as follows.

a. In the “New Drums” frame, notice the “XYZ” drum is listed. This occurred since was not initially defined in the “Drum List” table but was manually entered in the “Cable Schedule.

b. Click “Add to Drum List” button to add XYZ drum to the Drum List table.

c. Click “OK” to confirm the alert message.

d. Click “Close” button.
(7) On the “Drum Schedule” dialog window, click the “Edit Drum List…” to verify that the “XYZ” drum has been added.

(8) Navigate to row 62 of the “Drum List Editor” table and the “XYZ” drum is shown.

(9) Click “Close” button after the inspection.
(10) Similarly, click “Close” button on the “Drum Schedule” dialog window to conclude.